Back to overview
Degraded

Power Outage

Jun 17, 2025 at 7:08am UTC
Affected services
NeseOS Archive

Resolved
Jun 18, 2025 at 7:26pm UTC

We are resolved

Created
Jun 17, 2025 at 7:08am UTC

Due to power outage reasons, we are waiting to restore the power